Client request for 4.1 does not match server version 4.0.0

Trying to open the Admin client after starting it from console with grunt dev results in this text (“Client request for 4.1 does not match server version 4.0.0.”) being shown alongside the 404 Ghost image. The console shows the same error. This did not happen before, so it must be related to the version update.

I’m guessing I have to update something somehow, but I’ve already tried pulling the latest version of the repository and running grunt master before starting up and I don’t know how else to go about updating.

URL: http://localhost:2368/ghost/ (just http://localhost:2368 works fine, but I need the admin)

I have Ghost installed from source according to these instructions.

I am using Firefox version 86.0.1 (64-bit). For reasons beyond my control, I can’t test on Chrome or Edge.

You should be able to update your ghost repo by running git pull upstream main. Since Ghost and Admin are 2 separate repos, make sure the Ghost repo gets updated :slight_smile:

I thought I’d already done that, but I did it anyway and then ran grunt master and grunt dev again. Things did change, but unfortunately for the worse. Now I can’t connect to either http://localhost:2368/ghost or http://localhost:2368/. I only get the Firefox “Unable to connect” page for both. (There are no connectivity or firewall problems as all other sites load normally.)

The command line output claims that the server running, but it reports no requests being made. The Firefox network monitor doesn’t show any requests being made upon refreshing, either. Something that may be related, though, is that it complains about not being able to find module @tryghost/limit-service:

cannotfindmoduleghosterror

After this message, it begins building the admin client anyway and everything looks normal after that. I don’t think it complained about this before when things were working, but I could be wrong.

Did you run yarn after pulling? Seems like your dependencies might be out of date :slight_smile:

As an aside, you might run into random errors working on Ghost in Windows. If you’re able to, WSL for Windows gives you a Linux environment that is well integrated.

I tried that and the error still persisted, so I got to the point where I just decided to uninstall and reinstall the whole thing - and now it works fine again. :woman_shrugging: Thanks anyway for taking the time to help me.