Downloading Ghost step 5/5 took over 20 mins

I tried installing Ghost (v 2.27.0) via Ghost CLI on my host’s ssh using the command:

ghost install --no-setup-linux-user

During the first 2 installs, I could get to the “Enter your blog URL” step pretty fast. (I entered an incorrect MySQL username so I had to tried again).

When installing Ghost the third time, it seemed to get stuck at step 5/5 Building fresh packages.

I waited 10 to over 30 minutes & tried again 3-4 times, but it was still showing the Downloading line at step 5/5 every time. Is this normal? Do you guys have any ideas for fixing?

Host info: CentOS 7 (it works fine from many users’ experience)
Browser: Chrome
SSH Client: PuTTy

Hey there, that doesn’t seem right. What’s the output showing if you run it with the --verbose flag?

When I run ghost --verbose in the same install folder, it shows:

Unrecognized command: ‘–verbose’. Run ghost help for usage.

Hi, I tried ghost install --no-setup-linux-user --verbose

[01:25:13] → yarn install v1.16.0
[01:25:13] → [1/5] Validating package.json…
[01:25:13] → [2/5] Resolving packages…
[01:25:14] → [3/5] Fetching packages…
[01:25:17] → [4/5] Linking dependencies…
[01:25:34] → [5/5] Building fresh packages…

Still loading…

Hi @vanjungg, I’ve just checked with the team and I’m afraid we don’t support centos in the CLI. There’s not much we can do, unless you have some familiarity with the code and are able to debug what is happening?

Sorry for not being able to help you further with this issue

1 Like

Using the --verbose flag & switching to Bitvise SSH client did the trick! Thank you @DavidDarnes, you helped me!

1 Like