Email failed to send - please verify your email settings 📧

Hi everyone,
Ubuntu 18.04
Ghost Version 3.32.2
Environment production
Database mysql
Mail SMTP
Url private

This is the json:

"mail": {
  "transport": "SMTP",
  "options": {
    "service": "Mailgun",
    "host": "smtp.eu.mailgun.org",
    "port": 465,
    "secureConnection": true,
    "auth": {
      "user": "postmaster@mg.******.it",
      "pass": "************************************"
    }
  }
},

I have updated and confirmed the email newsletter from the labs section.
I entered noreply@mydomain.it (the email noreply really exists).

The test newsletter email is working correctly.

What could be the problem?

1 Like

I updated to the latest version 3.33.0, the problem persists.

1 Like

I have the same problem, I was using Ghost 3.19.0 and upgraded to 3.33.0 and the error continues

I haven’t been able to fix it yet

1 Like

I contacted Mailgun support to check if there was any restriction or block on my account, I was informed that it was not.

I checked all the Ghost settings again and they are all ok, the registration emails, login, invitations from new authors, are being sent normally, only the newsletter that is not sent.

I’m using Ghost 3.33.0, on a DigitalOcean VPS running Ubuntu 18.04 (LTS) x64.

I have a similar problem. When testing the signin/signup forms this same error keeps showing up. I assume the error would be the same if I sent emails with Ghost.

My setup is exactly the same.

Which Mailgun API key are you using? I’m using the private one, I don’t have any luck with the public one.

1 Like

I’m also using Mailgun’s private key, but yesterday, mysteriously, Ghost started sending the Newsletter again, without me doing anything.

1 Like

I tried to enter the API KEY again, the problem persists

1 Like

I updated to the latest version 3.34.0 , the problem persists.

1 Like

I can’t afford this so I decided to switch to GhostPro for this month. An input from team Ghost would be great to see where the problems is…

I updated my Ghost local installation and the problem also didn’t go away.

I hope, but I am sure, that the Ghost team is investigating the problem, so they have no answer yet.

1 Like

I updated to the latest version 3.34.1 , the problem persists.

1 Like