Error while using GScan

I am unable to use the GScan tool ( as it is throwing an error when I am uploading a zip file. This issue is probably the same as Gscn showing error white uploading zip file but that has been locked so I am creating a fresh post.

The error I am getting is

Please select a valid zip file.

UnsupportedMediaTypeError: Please select a valid zip file. at new UnsupportedMediaTypeError (/opt/gscan/shared/node_modules/ghost-ignition/lib/errors/index.js:128:23) at uploadValidation (/opt/gscan/releases/2019-07-11T06:56:38.910Z/app/middlewares/upload-validation.js:37:21) at Layer.handle [as handle_request] (/opt/gscan/shared/node_modules/express/lib/router/layer.js:95:5) at next (/opt/gscan/shared/node_modules/express/lib/router/route.js:137:13) at Immediate._onImmediate (/opt/gscan/shared/node_modules/multer/lib/make-middleware.js:53:37) at runCallback (timers.js:706:11) at tryOnImmediate (timers.js:676:5) at processImmediate (timers.js:658:5)

I want to upgrade to v2 and the guide says to use the GScan tool to make sure the theme works. Any idea what’s wrong?

I am also facing same issue since last month

Can you please share:

  1. operating system and browser that you are using
  2. an example of a zip file that isn’t working

I’m not able to reproduce on mac chrome with the zip file downloaded from

I am using Windows 10 1903 and tried on Chrome 75 and Firefox 64. I have tried uploading the zip downloaded from the Casper github repo as mentioned above and it fails too. So, I checked using a colleagues Mac chrome and my custom theme as well as the github zip works fine. It seems like its an issue isolated to the Windows environment.

@SayakMukhopadhyay That’s super useful, thank you.

Could you try uploading to again now? I think I fixed it.

1 Like

Yup, it works just fine now. Thanks for the quick response.
Pinging @themeix since they might might be interested.

1 Like

Thanks… Its working now… I created a topic ( Gscn showing error while uploading zip file ) last month but did not get attention of @Hannah that time…

Sorry about that. If you ever encounter bugs like this with gscan you can always raise them here as well:

1 Like