# Ghost unable to start after inproper database shutdown

**URL:** <https://forum.ghost.org/t/ghost-unable-to-start-after-inproper-database-shutdown/42762>\
**Category:** Developer help\
**Created:** [November 17, 2023, 2:21am UTC](https://forum.ghost.org/t/ghost-unable-to-start-after-inproper-database-shutdown/42762 "2023-11-17T02:21:41Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Josh2](https://avatars.discourse-cdn.com/v4/letter/j/4491bb/32.png) [@Josh2](https://forum.ghost.org/u/Josh2)\
**Post date:** [November 17, 2023, 2:21am UTC](https://forum.ghost.org/t/ghost-unable-to-start-after-inproper-database-shutdown/42762/1 "2023-11-17T02:21:41Z")

</div>

Hi,

This evening I’ve had a bit of hard time trying to get Ghost running from a Database that was improperly shut down.

## When trying to start ghost, I see that it attempts to [2023-11-17 02:11:26] INFO Ghost is running in production… [2023-11-17 02:11:26] INFO Your site is now available on [2023-11-17 02:11:26] INFO Ctrl+C to shut down [2023-11-17 02:11:26] INFO Ghost server started in 0.966s [2023-11-17 02:11:37] ERROR Invalid database host. Invalid database host. “Please double check your database config.” Error ID: 500 Error Code: ETIMEDOUT

Error: connect ETIMEDOUT  
at /var/lib/ghost/versions/5.73.1/node\_modules/knex-migrator/lib/database.js:50:23  
at Connection.\_handleTimeoutError (/var/lib/ghost/versions/5.73.1/node\_modules/mysql2/lib/connection.js:205:17)  
at listOnTimeout (node:internal/timers:569:17)  
at process.processTimers (node:internal/timers:512:7)  
[2023-11-17 02:11:37] WARN Ghost is shutting down

- How was Ghost installed and configured?  
Ghost is running on Docker, running the latest version. The database is running on MySql Version 8.0.35 on Ubuntu 20.04

- What errors or information do you see in the console?

See above! 🙂

Any help is really appreciated.  
Thanks,  
Josh
