Ghost update stuck building packages


#1

Hi,

I’m trying to update my ghost installation (currently Ghost-CLI version: 1.8.1
and Ghost Version: 1.7.0) to the latest release (v.1.25.2), and it seems to me that update process gets stuck at “[5/5] Building fresh packages…”.

How long should this process usually take?
(Posting at 17:04 local time, i.e. an hour has passed)

user@server [ghost installpath] $ ghost update -V
[15:57:39] Checking system Node.js version [started]
[15:57:39] Checking system Node.js version [completed]
[15:57:39] Ensuring user is not logged in as ghost user [started]
[15:57:39] Ensuring user is not logged in as ghost user [completed]
[15:57:39] Checking if logged in user is directory owner [started]
[15:57:39] Checking if logged in user is directory owner [completed]
[15:57:39] Checking current folder permissions [started]
[15:57:39] Checking current folder permissions [completed]
[15:57:40] Checking folder permissions [started]
[15:57:52] Checking folder permissions [completed]
[15:57:52] Checking file permissions [started]
[15:57:53] Checking file permissions [completed]
[15:57:53] Checking content folder ownership [started]
[15:57:53] Checking content folder ownership [completed]
[15:57:53] Checking memory availability [started]
[15:57:53] Checking memory availability [completed]
? Checking for available migrations
? Checking for latest Ghost version
[15:58:01] Downloading and updating Ghost [started]
[15:58:03] Downloading and updating Ghost to v1.25.2 [title changed]
[15:58:03] Getting download information [started]
[15:58:11] Getting download information [completed]
[15:58:11] Downloading [started]
[15:58:17] Downloading [completed]
[15:58:17] Installing dependencies [started]
[15:58:22] ? yarn install v1.7.0
[15:58:26] ? [1/5] Validating package.json...
[15:58:26] ? [2/5] Resolving packages...
[15:58:43] ? [3/5] Fetching packages...
[15:59:41] ? info source-map@0.7.3: The engine "node" is incompatible with this module. Expected version ">= 8".
[15:59:41] ? info "source-map@0.7.3" is an optional dependency and failed compatibility check. Excluding it from installation.
[15:59:41] ? [4/5] Linking dependencies...
[16:04:01] ? [5/5] Building fresh packages...

#2

For future reference, should anyone find this thread, the update progressed after ~ 2 hours:

[18:06:27] ? info This module is OPTIONAL, you can safely ignore this error
[18:16:17] Installing dependencies [completed]
[18:16:17] Downloading and updating Ghost to v1.25.2 [completed]
[18:16:17] Stopping Ghost [started]

I am running Ghost on a Raspberry Pi 2 Model B (Revision: a01041).


#3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.