Ghost v4 Fresh Install - 401 Unauthorized /members/api/members

Continuing/Moving my Topic Reply from Upgrade to Ghost v4, but a lot of 503 error:

I’m creating a new Topic for this issue because my post there relates not to an upgrade to v4, but to a v4 fresh install. (When I had successfully Upgraded the site from v3 to v4, at first everything worked – that is until I stopped the freshly updated instance, when restarting it stopped working as others have also found.)

Other than this error (below), so far this fresh Ghost v4 install is working, even after stopping and restarting this fresh Ghost instance the site is behaving properly.

Here is the post:

OK, fresh, new install of Ghost 4 on new subdomain, then restarted the instance and cleared all the caches (including Cloudflare), still get this error (and only after I refresh the page, not upon first arrival at the page):

And here is the Stack Trace:

a []( sessionData []( e/< []( c []( u/o._invoke</< []( v/</< []( b []( i []( (Async: promise callback) b []( i []( v/</< []( v/< []( e/< []( c []( u/o._invoke</< []( v/</< []( b []( i []( v/</< []( v/< []( mr</<.value</< []( e/< []( c []( u/o._invoke</< []( v/</< []( b []( i []( v/</< []( v/< []( mr</<.value</< []( e/< []( c []( u/o._invoke</< []( v/</< []( b []( i []( v/</< []( v/< []( mr</<.value</< []( value []( rl []( pu []( n.unstable_runWithPriority []( Ua []( su []( Gl []( $l []( Iu []( Uu/< []( Zl []( Uu []( n.render []( <anonymous> []( <anonymous> []( t []( <anonymous> []( t []( <anonymous> []( <anonymous> []( t []( <anonymous> []( t []( <anonymous> []( <anonymous> [](

That request is made by Portal, and used to see who you are :slight_smile: Getting a 401 just means you’re not signed in.

I just successfully logged in, and do still see that error.

Is that new in v4, @vikaspotluri123 ? I never saw that error come up in v3…

I noticed in v4 the removal of the toggle to enable/disable Members that was in v3:

I miss that.

See this other post. Others agree: Ghost 4.0 - Really Terrible for Personal Blog

@denvergeeks the 401 response is expected with current implementation. We are looking into other ways of handling this request, but for current version: “it’s not a bug, it’s a feature” :slight_smile:

1-console-error failed-to-load unauthorized

Like a tiny, evil pair of eyes, staring me down … taunting me in the dark of night …

1 Like

I’m having the same issue on fresh v4 install using digital ocean marketplace. I did very little and getting 401 unauthorized on the apiv2 and api/member, then api/send-magic-link get attempts.

No idea what to do.

@luccast if you’re getting 401s for more than /members/api/member/ then you’re describing a different problem. Please open a new topic and include as many details as possible

I think the API v2 is deprecated in Ghost 4.0 and the themes built for API v2 will not function properly with Ghost 4.x.x

You will have to scan the theme via and fix the issues to get it working on Ghost 4.x.x

Lol… Me too. But I also kind of like the taunting.

We have no members, but after we had updated to 4 version I have such message in Console:
GET https://**/blog/members/api/member/ 401 portal.min.js:3.
How can I remove it? We aren`t going to use paid members. Please, help :pleading_face:

Hey there @Svetlana_Tsupryk – If you update to version 4.4.0 you can disable the whole membership banana and get rid of the error message as well …


Thank you very much!

1 Like

That phrase is too funny not to comment on. I like it - peel the layers like a banana.