Gmail configuration

Error sending email! Error sending email: Failed to send email. Reason: connect ECONNREFUSED my.server.ip:587. Please check your email settings and resend the invitation.

"mail": {
    "transport": "SMTP",
    "options": {
      "service": "Google",
      "host": "smtp.gmail.com",
      "port": 587,
      "auth": {
        "user": "my gmail",
        "pass": "my secure app password"
      }
    }
  },

Server - Linode VPS with blocked ports OPEN. Ghost runing on Cloudron

I think you need to add "secure": false, under options, since TLS negotiates in plain text (I suspect 465 may work with this config.)

Furthermore, try running another app from the command line to see if you can establish a connection, e.g., openssl s_client -connect smtp.gmail.com:587, which returns … Secure Renegotiation IS NOT supported ….

Tried every port with secure false and true but still it’s not working

Check with another app as suggested. What output do you have?

Now iam getting another error, for now my site is invite only and I will verify staff emails directly through MySQL database, then in future shift it to ghost pro.
Thanks for help