Gscan claims `ghost-api` is deprecated but official docs still recommend it


I just updated my local ghost and gscan to latest versions

$ gscan -v
$ ghost -v
Ghost-CLI version: 1.18.2
Ghost version: 4.40.0

and then I run gscan to check if my theme still has no errors, and I got the following:

$ gscan content/themes/strider

Checking theme compatibility...

Your theme has 1 warning!

- Warning: package.json property "engines.ghost-api" is deprecated.
Files: package.json

Get more help at
You can also check theme compatibility at

but the documentation still says using engines.ghost-api is ok.

The exact code in my package.json is

"engines": {
	"ghost": ">=4.0.0",
	"ghost-api": "v4"

What should I replace ghost-api with since it’s deprecated, but the official documentation still recommends it?

You can remove the ghost-api key from your package.json file. You will no longer receive the error.

Yes, I removed it and everything seems to be working as expected.
Just odd that gscan throws an error for something that the documentation says is ok :slight_smile:

I think it’s something that’ll be removed in the future, and this is just a case of the code moving faster than the documentation :upside_down_face: