Incompatible module error


When I run “yarn setup” I get the following error:

error ghost@1.22.1: The engine “node” is incompatible with this module. Expected version “^4.5.0 || ^6.9.0 || ^8.9.0”.

What should I do about it? I use the most recent node version.


You need node 4,6 or 8 to run ghost! If you’re running latest that’s probably v9. You can use something like nvm to switch between node versions, or you can downgrade. You probably want to run using v8 if you have no preference since it’s faster.


Well, I downgraded to 8.11.1 but got a new error:

Running “symlink:githooks” (symlink) task

Error: EPERM: operation not permitted, symlink ‘…github\hooks\pre-commit’ -> ‘C:\WebDevelopment\Ghost.git\hooks\pre-commit’
Warning: Failed to create symlink: (file) .git/hooks/pre-commit -> …github\hooks\pre-commit. Use --force to continue.

Aborted due to warnings.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.