Initial Account Creation fails consistently

My previous posts provides all the info RE my OS and configuration. While my previous problem appears to be solved, the new problem is when creating a new instance (/usr/local/www/{new site}, starting that instance for the first time, browsing to the new site and filling in the first/new account: hit “Create Account & Start Publishing”, I get the error:
» Request was rejected due to server error

The error is not accurate, regardless, what is amiss where this function fails consistently?

Obviously I have everything set up: DNS record, NGINX, MariaDB, config.production.json (copy of prior install with site specific tweaks)

PS: Ran ‘ghost doctor’ prior to running start and got all green lights.

Since it sounds like you followed the standard installation process, the Ghost logs can be seen with:

 journalctl -u '*ghost*'

Do they show any errors that are intersting when you get this “server error” message?

1 Like

Thanks for writing Mark.
In the meantime, I’ve solved the problem which may have been a culmination of several factors:

  • Fine-tuned NGINX configuration, esp. fcgi needed attention
  • Switched all hosted sites to NGINX which allowed me to standardize on ports used rather than using alternate ports to keep it from colliding with Apache
  • Got email service to work with my Google provider

The latter is very likely the culprit because Ghost didn’t have a way to message a new user and verify authenticity.

Thank so much for checking back!
That motivated me to close the case :smiley:

Have a great weekend :shamrock:

1 Like