Local ghost install help - Litespeed Webserver

Hi, need help with local ghost install on the following server details:

[root@darkice ~]# uname -arn
Linux 3.10.0-1160.11.1.el7.x86_64 #1 SMP Fri Dec 18 16:34:56 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

LiteSpeed Web Server Enterprise 5.4.11
[root@darkice ~]# mysql -V
mysql Ver 15.1 Distrib 10.3.27-MariaDB, for Linux (x86_64) using readline 5

I had it working OK before but looking for a professional install because I ran into problems with the vhost with ghost constantly stopping randomly… and when rebooting server ghost would never start/etc… need professional help here on how to making things work better and for updates of Ghost to work more reliably /etc.

The letsencrypt and vhost and everything is already setup, everything is already done here except for Ghost… just need help with ghost install and want to watch over TeamViewer or another remote view tool so I can learn…

I can pay for help in advance and already have backups… also need help with a theme for this site and customize the adsense for it… please let me know if you can help…



Thanks I sent an email – please let me know if you received… from avery@abdomination (dot)[com]

You’re probably not using a supported tech stack (LiteSpeed) and you would be better of installing Ghost on nginx, but drop me a message and I can try to help with your issue.

You can also try to reach out to Dan here: https://gloat.dev/ (he offers professional services) or even the Ghost team here: https://valet.ghost.org/.

Hey Daniel, I tried contacting Dan but he wasn’t able help with local install. Also the Ghost team can’t help and I have had not luck with 3 other services either (don’t do local installs). Actually, the LiteSpeed team got this working before and it worked perfectly other than one issue where for whatever reason my blog would stop randomly for no apparent reason and I would need to manually Ghost start it again… every few hours… this was a “development mode” ghost though…

I would rather not run two different webservers on the server so maybe we can try and get it lucky and fix it or whatever, and not run it in “development mode”, not sure… I will send you a message.

Also I waned to let you know I did not yet seek professional help about the issue with the old blog randomly stopping, just gave up on that… guessing it could probably be fixed… Everything seemed fine other than that really, and the blog didn’t start when server was rebooted…

I’ll send you a message to chat more, thanks for your help and just so you know I still haven’t found anyone for this project