Mail > Can not use IPv4 addresses with current networt

Hi.

I get this warning when i try to send a invite (Staff user invite):

Error sending email! Error sending email: Failed to send email. Reason: Can not use IPv4 addresses with current network. Please check your email settings and resend the invitation.

My site is: https://www.futurenode.dk

Ghost-CLI version: 1.21.1
Ghost version: 5.7.0 (at /var/www/ghost)
Node: v16.16.0
NPM: 8.15.1
Ubuntu 20.04 LTS

EDIT - My mail config from “config.production.json”:

  "mail": {
    "from": "'FutureNode.dk' <no-reply@futurenode.dk>",
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "smtp.eu.mailgun.org",
      "port": 465,
      "secureConnection": true,
      "auth": {
        "user": "no-reply@mailgun.futurenode.dk",
        "pass": "MYPASSWORD"
      }
    }
  },

Regards

Thomas

Not sure why you’re getting that error, but I also note that your site is unreachable. You may want to check your OS network setting, and maybe try apt update, for example, to see if this resolves hostnames.

Incidentally, you may want update the config for port 587 since 465 is depreciated.

  "mail": {
    "from": "<email>",
    "transport": "SMTP",
    "options": {
      "host": "smtp.eu.mailgun.org",
      "port": 587,
      "service": "Mailgun",
      "secure": false,
      "requireTLS": true,
      "auth": {
        "user": "<email>",
        "pass": "<password>"
      }
    }

Hi :slight_smile:

I updated my config to the settings @mjw say, and now it works :slight_smile:

Thanks.

1 Like