Migrating Content - Not able to resolve author_id

I’m trying to migrate content to new setup. JSON file is too big, so have to split into files.

Attempt 1

My thought process was to first import:

  • users
  • post_authors
  • post_meta
  • post_tags
  • roles
  • roles_users

Success! Can see post authors, tags, etc.

Then I imported:

  • posts

This is where things break. No matter what I do I just can’t get my posts to assign to the right author_id.

This is the error I get:

Post: Entry was imported, but we were not able to resolve the following user references: author_id. The user does not exist, fallback to owner user.

Attempt 2

This time I tried deleting 90% of the posts (reduced file size to manageable size), and imported everything in one file. Success - works like a charm!

So, I figure all I need to do is keep importing the rest of the posts data. Unfortunately this is where the same error comes up. It can’t resolve the author_id.

Does anyone have any ideas or suggestions or how to solve this?

Thanks in advance.

I think I solved it. Latest full import seems to have worked.

Ended up bumping my nginx config file temporarily.


client_header_timeout  600;
client_body_timeout    600;
send_timeout           600;
proxy_connect_timeout 600;
proxy_send_timeout 600;
proxy_read_timeout 600;