# New installation ERR\_SSL\_PROTOCOL\_ERROR

**URL:** <https://forum.ghost.org/t/new-installation-err-ssl-protocol-error/14500>\
**Category:** Installation\
**Created:** [May 19, 2020, 11:12am UTC](https://forum.ghost.org/t/new-installation-err-ssl-protocol-error/14500 "2020-05-19T11:12:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![MrEngineer13](https://sea1.discourse-cdn.com/flex015/user_avatar/forum.ghost.org/mrengineer13/32/7996_2.png) [@MrEngineer13](https://forum.ghost.org/u/MrEngineer13)\
**Post date:** [May 19, 2020, 11:12am UTC](https://forum.ghost.org/t/new-installation-err-ssl-protocol-error/14500/1 "2020-05-19T11:12:44Z")

</div>

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

- What’s your URL? [mrengineer13@live.com](mailto:mrengineer13@live.com)

- What version of Ghost are you using? 3.14.0, tried installing 1.x but it wasn’t compatible with node

- What configuration?  
server {  
listen 80;  
listen [::]:80;

server {  
listen 443 ssl http2;  
listen [::]:443 ssl http2;

```
server_name site .com;
root /website_path/ghost/system/nginx-root; # Used for acme.sh SSL verification (https://acme.sh)

ssl_certificate /etc/letsencrypt/mrengineer13.com/fullchain.cer;
ssl_certificate_key /etc/letsencrypt/mrengineer13.com/mrengineer13.com.key;
include /etc/nginx/snippets/ssl-params.conf;

location / {
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto $scheme;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header Host $http_host;
    proxy_pass http://127.0.0.1:2369;

}

location ~ /.well-known {
    allow all;
}

client_max_body_size 50m;

```

}

- What browser? Brave/FF/Chrome
- What errors or information do you see in the console?  
In the browser I’m getting ERR\_SSL\_PROTOCOL\_ERROR.  
When I curl -I the domain I get 502 error. When I try to check the journalctl -e I get unrelated logs.

What steps could someone else take to reproduce the issue you’re having? Have existing site and then install new one

I have been trying to update ghost, I’m on 0.3.x, so I am trying to migrate domains, I tried to migrate first to 1.x but my node version is too new so I’m trying to install version 3 clean and try to migrate my posts.

I am running nginx so I removed the old domain from /sites-enabled/, the old let’s encrypt certs for the www. domain - along with the A-records from my DNS (Digital Ocean).

Ghost.service won’t start and the errors in /content/logs are empty, any ideas?

---

<div class="post-metadata">

**Author:** ![MrEngineer13](https://sea1.discourse-cdn.com/flex015/user_avatar/forum.ghost.org/mrengineer13/32/7996_2.png) [@MrEngineer13](https://forum.ghost.org/u/MrEngineer13)\
**Post date:** [May 19, 2020, 10:36pm UTC](https://forum.ghost.org/t/new-installation-err-ssl-protocol-error/14500/2 "2020-05-19T22:36:22Z")

</div>

I got the answer on another thread, you can see the issue here: [Site accessable in Curl only - #4 by MrEngineer13 - Help - Let's Encrypt Community Support](https://community.letsencrypt.org/t/site-accessable-in-curl-only/123266/4). Basically I had to toggle ssl\_session\_tickets on even though I have a version of nginx newer than what the comment on that line specifies
