Production installation doesn't print the questions

I managed to smoothly install Ghost on my local machine and became hooked on it. I think it’s more elegant than Drupal, and want to move from Drupal to Ghost.

However, during the production installation, some of the questions aren’t printed on the screen and I have to keep guessing the answer. As a result, I’ve had to install and uninstall Ghost several times and still haven’t gotten it to work.

In addition, I keep getting the same error about zeroSSL. I’ve already configured https with Certbot and this could be causing the error, in addition to the question not being printed on the screen.

Message: Command failed: /bin/sh -c sudo -S -p ‘#node-sudo-passwd#’ /etc/letsencrypt/ --issue --home /etc/letsencrypt --domain --webroot /var/www/ --reloadcmd “nginx -s reload” --accountemail Y

Screen Shot 2021-09-25 at 12.02.06 PM

Debug Information:
OS: Ubuntu, v20.04.3 LTS
Node Version: v14.17.6
Ghost Version: 4.16.0
Ghost-CLI Version: 1.17.3
Environment: production
Command: ‘ghost install’

Cloud provider: Linode

Any guidance would be appreciated.

Here is the remaining installation process without the questions printed on the screen.

Here are the actual questions from a screenshot.

How odd! I’m just a newbie myself, but just in case, is it possible the terminal you’re using is setting the text colour to black? What terminal are you using? If you click and drag to highlight where the text is supposed to be, can you copy it?

The zeroSSL error is probably worth separate treatment, but again, just in case, you might want to try answering “no” to the SSL question. It may be expecting you haven’t already got https configured. You can always run ghost setup ssl later, which is what I did successfully to try to decouple a few of the fail-potential steps. It does a lot for you, including going and getting you a certificate from Let’s Encrypt. It sounds like all you need to do is create the correct conf file for nginx.

I’m using the macOS Big Sur terminal. It is odd that the questions didn’t print onscreen. The highlighting thing would have worked I think, but I never thought of it. I managed to grab the screenshot of the questions, so got it installed.

I found that the Ghost CLI is configured to auto renew the SSL certificate, so I’m cool with that issue now.

Thank you and God bless.

I just ran
$ ghost update

The prompt was hidden. I highlighted it and it showed. Thanks!

1 Like