Site doesn't work after setup through ghost-cli

#1

Hello. I tried to setup Ghost on my server. Log is below

sudo npm install ghost-cli@latest -g
npm WARN deprecated cross-spawn-async@2.2.5: cross-spawn no longer requires a build toolchain, use it instead
/usr/bin/ghost -> /usr/lib/node_modules/ghost-cli/bin/ghost
+ ghost-cli@1.9.9
added 355 packages from 189 contributors in 22.275s
user@ruvds-mjsez:~$ sudo mkdir -p /var/www/ghost
user@ruvds-mjsez:~$ sudo chown user:user /var/www/ghost
user@ruvds-mjsez:~$ sudo chmod 775 /var/www/ghost
user@ruvds-mjsez:~$ cd /var/www/ghost
user@ruvds-mjsez:/var/www/ghost$ ghost install
✔ Checking system Node.js version
✔ Checking logged in user
✔ Checking current folder permissions
✔ Checking operating system compatibility
✔ Checking for a MySQL installation
✔ Checking memory availability
✔ Checking for latest Ghost version
✔ Setting up install directory
✔ Downloading and installing Ghost v2.19.4
✔ Finishing install process
? Enter your blog URL: https://example.ru
? Enter your MySQL hostname: localhost
? Enter your MySQL username: root
? Enter your MySQL password: [hidden]
? Enter your Ghost database name: ghost_prod
✔ Configuring Ghost
✔ Setting up instance
+ sudo useradd --system --user-group ghost
+ sudo chown -R ghost:ghost /var/www/ghost/content
✔ Setting up "ghost" system user
? Do you wish to set up "ghost" mysql user? Yes
✔ Setting up "ghost" mysql user
? Do you wish to set up Nginx? Yes
✔ Creating nginx config file at /var/www/ghost/system/files/example.ru.conf
+ sudo ln -sf /var/www/ghost/system/files/example.ru.conf /etc/nginx/sites-available/example.ru.conf
+ sudo ln -sf /etc/nginx/sites-available/example.ru.conf /etc/nginx/sites-enabled/example.ru.conf
+ sudo nginx -s reload
✔ Setting up Nginx
? Do you wish to set up SSL? Yes
? Enter your email (For SSL Certificate) mail@example.ru
+ sudo mkdir -p /etc/letsencrypt
+ sudo ./acme.sh --install --home /etc/letsencrypt
+ sudo /etc/letsencrypt/acme.sh --issue --home /etc/letsencrypt --domain example.ru --webroot /var/www/ghost/system/nginx-root --reloadcmd "nginx -s reload" --accountemail mail@example.ru
+ sudo openssl dhparam -out /etc/nginx/snippets/dhparam.pem 2048
+ sudo mv /tmp/ssl-params.conf /etc/nginx/snippets/ssl-params.conf
✔ Creating ssl config file at /var/www/ghost/system/files/example.ru-ssl.conf
+ sudo ln -sf /var/www/ghost/system/files/example.ru-ssl.conf /etc/nginx/sites-available/example.ru-ssl.conf
+ sudo ln -sf /etc/nginx/sites-available/example.ru-ssl.conf /etc/nginx/sites-enabled/example.ru-ssl.conf
+ sudo nginx -s reload
✔ Setting up SSL
? Do you wish to set up Systemd? Yes
✔ Creating systemd service file at /var/www/ghost/system/files/ghost_example-ru.service
+ sudo ln -sf /var/www/ghost/system/files/ghost_example-ru.service /lib/systemd/system/ghost_example-ru.service
+ sudo systemctl daemon-reload
✔ Setting up Systemd
? Do you want to start Ghost? Yes
+ sudo systemctl is-active ghost_example-ru
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
+ sudo systemctl is-active ghost_example-ru
✔ Validating config
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
+ sudo systemctl start ghost_example-ru
✔ Starting Ghost
+ sudo systemctl is-enabled ghost_example-ru
+ sudo systemctl enable ghost_example-ru --quiet
✔ Enabling Ghost instance startup on server boot

Ghost uses direct mail by default. To set up an alternative email method read our docs at https://docs.ghost.org/concepts/config/#mail

------------------------------------------------------------------------------

Ghost was installed successfully! To complete setup of your publication, visit:

    https://example.ru/ghost/

When I open this in my browser, site is not available.
Help me, please. What was wrong with it?

#2

Don’t have enough info to help - can only suggest that you need to check you have an A record setup for your URL and that it has finished propagating.

#3

yes, A record setup. Before setup ghost nginx response “welcome page” for URL

#4

There was conflict with another my site. Thanks for attempt to help me