[solved] All posts behind either a subscription banner or paywall. Even Public ones. What have I done wrong?

Happy Thursday!

I’ve been trying out the flows of having a member (not a paid-member) and allowing these “members” access to content.

After playing a few scenarios, I’ve just realised that my “Members Only” posts cannot be seen by logged-in Members. They get the " This post is for paying subscribers only" when the post in fact is NOT a paid post and they are in fact “Members” (confirmed by having them listed down in the Members dashboard).


Would love any guidance on what I may have done wrong in the set up, please? Struggling to debug :slight_smile:

Please let me know if you need any more info :slight_smile:


update: New pointer: Actually, all posts with me as an author are behind a paywall, being them “members-only” or public.

This is Public/free post:

A post from Ghost, however, can be seen in full:

Only posts by Ghost are outside the paywall.

No idea how I’ve managed to do this :sweat_smile: Help?

Sounds like you’ve set the default visibility to “Members only” so any post you create from now on is behind the signup. You need to add yourself to your own members so you can see the posts.

Thanks for reverting @DavidDarnes

Sadly, I think the issue may be somewhere else.

For the case of not being able to see member-only posts while being a member: I am indeed a member (just double checked in the dashboard)

For the case of not being able to see even public posts: the public posts are indeed “public” (not “Members Only”) (see images)


Pointers of what else to check?

Oops, sorry, forgot to mention that you actually need to sign in to see them. Though I see you’ve updated the post access, did you click update after changing the post access?

Thanks again for reverting @DavidDarnes

Yep, I did sign in. And yes, I’ve clicked update. And nothing. everything behind paywall.

But as I was writing above, this seems bigger, I can’t even see Public posts. Everything is behind a subscription banner. Please see message above.

I’d love to know where else to look? Have tried a bunch of debugging, removing even the routes we exchanged messages in a post a few days ago and that doesn’t seem to be the cause for this.

Have you checked your main Members settings? If you create a new public post is that public?

Thanks @DavidDarnes for coming back.

There seems to be a bug related to this https://github.com/TryGhost/Ghost/commit/d6b0db39c0dd3c4b54883b776cb6d3ba206f4cc2. So for others in the future, update Ghost when the fix has been implemented.