SQLITE_READONLY Error when signing up new user on fresh Ghost install

If you’re looking for help, please provide information about your environment. If you delete this template and don’t provide any information, your topic will be closed.

If you aren’t running the latest version of Ghost, the first thing we will ask you to do is update to the latest version of Ghost.

  • What’s your URL? This is the easiest way for others to help you
  • What version of Ghost are you using? If it’s not the latest, please update Ghost first before opening your topic

And

  • How was Ghost installed and configured?
  • What Node version, database, OS & browser are you using?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

Hi, I finally had the time today to setup a blog and I chose Ghost. After setting it up and having it running, I went to sitename/ghost to register a new account. I am coming across an error that looks like this


"SQLITE_READONLY: attempt to write a readonly database"

I’ve set permissions to rwx (chmod 777) for every related folder and the DB itself. The folders I have rwx permissions are in the “root” folder of this project called myblog, myblog/content (everything in here), myblog/content/data (everything in here), and finally in myblog/content/data/ghost-local.db

I’m running Node v14.17.1 and Ghost 4.7.1 (newest version). I don’t really want to give out my URL since it’s the IP for my development lab machine, but I can if needed. I’m running it on a ‘VirtualHost’ inside of Apache following the instructions from https://www.howtoforge.com/tutorial/how-to-install-ghost-blog-on-ubuntu/

I don’t think Apache is the issue since my site runs fine, just when I go to sign myself up on the admin page, I get that DB error.

Here’s what my permissions look like


Thank you, any help is greatly appreciated!

Of course after reinstalling Apache and Ghost it works and I didn’t even have to touch permissions!