Subscription (Members) doesn't work with local mailserver

I’m using latest docker setup with email settings passed in environment variables.

Test email works.

Account recovery email works.

Member subscription does not work.

I have also tried with a free Mailgun account entered into the settings and it again doesn’t work.

The subscription email page keeps twirling with no message of failure or success and no emails sent out via mailgun or local.

Is this a known bug. Any workaround or fix?

Hi @oculux,

the mailgun setting in the ghost admin section is only for sending the newsletters.
In order to send member related mails such sign up, sign in, you have to configure
the config.production.json (found in your root ghost folder) accordingly.
If you want to use mailgun to send member related emails it should look something like this:

"mail": {
    "transport": "SMTP",
    "options": {
        "service": "Mailgun",
        "host": "",
        "port": 465,
        "secureConnection": true,
        "auth": {
            "user": "",
            "pass": "1234567890"

You can also find more about configuring your mail under: :slight_smile:

1 Like

Thanks for the reply.

I am using a Docker container and found it was using “Direct” in the default config.production.json and that was working for account recovery and test emails.

So I know the local email server works.

I have made a volume type link to my local file system and now created an explicit config.production.json with the “SMTP” type with relevant details pointing to my local mailserver.

Again the account recovery and test emails work.

What doesn’t work is the Subscribe page.

Any email that is entered sends the swirling snake - the button animation into an endless wait. Nothing happens.

I see no attempt to communicate with the mailserver that has been set up and confirmed to be working with the other email features of the installation.

The Subscribe page never subscribes anyone… does not give a succeeded or failed response.

The swirling snake animation just continues with no apparent action.

Maybe check the error.log in /content/logs to see if there is a problem.