The member setting needs a refresh to become active?

Yes, odd subject line.

You can check out what I mean over here.

If you don’t wanna open the link:

  1. I go on my wife’s phone (she is a subscriber/ member) and go over to my homepage ‘volleybrains.com
  2. All articles are ‘locked’ from a certain line for non members (so I’ve got the public preview working).
  3. On the first article I scroll down and hit the ‘subscription form’, even though my wife is a member
  4. Through the header menu I go back to the homepage
  5. I enter the same article again and now the ‘subscription form’ is gone and I can scroll completely down

This will be an issue for every recurring visitor…

How to fix this?

What version are you running

Excuse me.

Running 4.3.3.
On a DO droplet. Through Cloudflare.

Can you try disabling any caching on Cloudflare to rule that out? From the behaviour it looks like that may be the cause.

Thanks @Kevin I added a Page Rule and put a Bypass on any volleybrains.com/* page.

When I checked that didn’t resolve the issue though. When I erased the entire browser history (cookies, cache…everything) And sign in again, yes it worked and kept on working.

So still no clue if this did it or it was just cleaning the browser up…

Can I keep that Page Rule running?