Unable to add more images via custom settings?

I’m trying to adjust a theme, so I can upload two additional logo images, but I’m running into issues. Maybe someone has an idea what can be the cause:

I added two additional custom settings with type “image” to the package.json.
In the Ghost admin panel, these new settings are displayed correctly.

But the “Upload Image” buttons in the admin panel for those two new images are not working properly, because they do not upload the second/third image, but only act like duplicates for the first image upload button:

When I delete the first image, I can click any of the 3 upload buttons and the uploaded file will be added as the first image… So there are two more buttons, but their functionality is that of the first button. When an image is already present for the first logo, the other buttons are unresponsive.

I checked the docs and cannot figure out what could be wrong. There is no mention of any limits on type “image” for custom settings.

This is the part of my package.json… the two footer_logo images are the new settings.

      "dark_mode_logo": {
        "type": "image"
      "footer_logo": {
        "type": "image"
      "footer_logo_dark": {
          "type": "image"
      "typography": {

This is the ghost admin panel displaying the new setting options:

I tried this locally and on a live site.
I did a ghost restart, and I switched to another theme and back, just to be sure.
I deleted cache…and so on. No changes.
There are less than 20 custom settings total, so it cannot be an issue with the custom setting limit.

Does anyone have an idea what could be the issue here?

This definitely worked in the old editor. I think you found a bug with the new editor. :frowning:

Yeah, I can validate, for Ghost 5.70.1. I also tried putting the images in different groups. Still no impact. Looks like both upload buttons get the same id assigned to them.

I’ll open a Github bug for the dev team.

1 Like

Thanks for checking and opening the issue @Cathy_Sarisky !

At least it’s not my imagination and will hopefully be fixed soon :D …

1 Like

Thanks for sharing this issue and making the bug report! I was able to repro this issue. The team is investigating this now, and I’ll report back when resolved/updated.

Our engineers identified the bug and put together a fix. I’ll post another update once it goes live.

1 Like

A fix went out in v5.70.2 :tada:


Wow, thanks guys for fixing this so quickly!
And thanks for the updates @RyanF :)