# Unable to browse site - Memory Availability Error

**URL:** <https://forum.ghost.org/t/unable-to-browse-site-memory-availability-error/861>\
**Category:** Developer help\
**Created:** [April 12, 2018, 5:50am UTC](https://forum.ghost.org/t/unable-to-browse-site-memory-availability-error/861 "2018-04-12T05:50:11Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![owenlearnstocode](https://sea1.discourse-cdn.com/flex015/user_avatar/forum.ghost.org/owenlearnstocode/32/396_2.png) [@owenlearnstocode](https://forum.ghost.org/u/owenlearnstocode)\
**Post date:** [April 12, 2018, 5:50am UTC](https://forum.ghost.org/t/unable-to-browse-site-memory-availability-error/861/1 "2018-04-12T05:50:11Z")

</div>

I am unable to browse my website nor ping it, but I can successfully ssh into my VPS host. Upon `ghost doctor`, it raises the error:

```auto
1) SystemError

Message: Ghost recommends you have at least 150 MB of memory available for smooth operation. It looks like you have 74 MB available.

```

My VPS has 1GB of RAM, and using the `free` command, it shows 467 MB of available memory and 868 MB of free swap capacity. I’ve read in another post here that this is only a bug with memory detection, so it should not cause real problems. So any way to pinpoint the real error? Thanks in advance!

```auto
Debug Information:
    OS: Ubuntu, v16.04
    Node Version: v6.14.1
    Ghost-CLI Version: 1.6.0
    Environment: production
    Command: 'ghost doctor'

```

---

<div class="post-metadata">

**Author:** ![Aileen](https://sea1.discourse-cdn.com/flex015/user_avatar/forum.ghost.org/aileen/32/9846_2.png) [@Aileen](https://forum.ghost.org/u/Aileen)\
**Post date:** [April 12, 2018, 6:23am UTC](https://forum.ghost.org/t/unable-to-browse-site-memory-availability-error/861/2 "2018-04-12T06:23:48Z")

</div>

Hey 👋🏼

Sorry to here that you’re having trouble. Yes, there is a known bug, but this is fixed now.

Can you please update the CLI (`sudo npm i -g ghost-cli@latest`) and try again?

You can also run the commands with the `--no-mem-check` flag to skip the memory check.

Let me know, if that solved the issue!

---

<div class="post-metadata">

**Author:** ![owenlearnstocode](https://sea1.discourse-cdn.com/flex015/user_avatar/forum.ghost.org/owenlearnstocode/32/396_2.png) [@owenlearnstocode](https://forum.ghost.org/u/owenlearnstocode)\
**Post date:** [April 12, 2018, 6:49am UTC](https://forum.ghost.org/t/unable-to-browse-site-memory-availability-error/861/3 "2018-04-12T06:49:00Z")

</div>

The update did the trick 🙂 thanks. I think it might have also been the client’s network problem. Anyway, it’s fixed for now, thanks again!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex015/uploads/ghost2/original/2X/b/ba9ce5100b8bb264586f4f572545596b2ce3f081.png) [@system](https://forum.ghost.org/u/system)\
**Post date:** [April 26, 2018, 6:49am UTC](https://forum.ghost.org/t/unable-to-browse-site-memory-availability-error/861/4 "2018-04-26T06:49:06Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
