Unable to create page with '#test' i.e. start the page title with # in 'Arate' theme

Please note in my local I have default theme and I am able to create the blog with page title as ‘#test’ but cant do so in production. as in preview ‘#’ is not displayed. How can i start my page title with ‘#’?

@raj08 Set up your theme so that whenever you use a particular internal tag (named #add-hash-to-title or something) the # is added directly before the title.

Thanks @Stromfeldt for your reply, I would like to highlight here, that the ‘#’ is displayed in the page title but it is not visible on the page, dont know why.
As, when I select the page title and copy/paste it, ‘#’ is present in front of the title
and in the browser as well ‘#’ is there in the page title
and in HTML title also ‘#’ is there in front of the page title.
But not visible on the page

I tried using internal tag option, but it’s not working, though I am not sure as I am not an expert. Great if you can elaborate on adding and using internal tag feature.