Upgrade 1.25.3 > 1.25.4 stuck at DB_NEEDS_MIGRATION


#1

Heyo!
I have a docker image based setup doing automatic upgrades for me and with a fallback of running a db upgrade if an image upgrade fails. However it seems the upgrade process has somewhat changed (or has it? :bug: :unicorn: )
So I’ve been running :beers::clinking_glasses: knex-migrator migrate :tumbler_glass::tropical_drink::cocktail::amphora::honey_pot: however been rewarded by
ERROR

NAME: DatabaseIsNotOkError
CODE: DB_NEEDS_MIGRATION
MESSAGE: Migrations are missing. Please run `knex-migrator migrate`.

level:normal

If knex-migrator is not installed, please run "npm install -g knex-migrator"
Read more here: https://github.com/TryGhost/knex-migrator
DatabaseIsNotOkError: Migrations are missing. Please run `knex-migrator migrate`.


#2

Nothing really has changed between 1.25.3 and 1.25.4, which causes this.

There is no need to execute knex-migrator manually, the Ghost-CLI takes this all over for you. I recommend using the existing Ghost docker repo.


#3

I can try to re-create this if you still have this issue. Cheers!


#4

Heyo thx for the offer: no-need :latin_cross:
I’ve just checked :white_check_mark: the whole process :leftwards_arrow_with_hook: once again :two: and the problem :bug: had been with the new docker image :cd: build :house: process, fixed :wrench: it and it all worked out just fine right away. so :ghost: tooling :hammer_and_wrench: had nothing to do with it…


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.