Upgrade local version of ghost


#1

Guys how can I upgrade the local version of ghost? I’m designing a theme and it’s having issues with the new - old version …

the command is ghost upgrade, but how do I do it, once I go to the folder on the terminal, and I type that it doesn’t recognize it


#2

What’s not recognized? The command? The instance?

Updating should be as easy as

cd /path/to/ghost && ghost install local
(wait for a new version to release)
cd /path/to/ghost && ghost upgrade


#3

I don’t know if it’s a freeze moment or what, so I’m opening the terminal, go to the dir.:

cd /Users/arturo/Documents/Arturo/Knowledge_center/Computer_Science/Projects/Ghost\ Theming/Ghost-0.11.12/

then type nodemon start and the instance starts, but on the same terminal it doesn’t let me keep typing, if I open a new tap without starting ghost, it doesn’t recognize it. I have the nvm installed, I tried nvm ghost upgrade and doesn’t work


#4

That’s expected, since nodemon will run until you terminate it (with control (or command, I don’t use OSX too often so I get them confused :man_shrugging: ) + c)

Ghost doesn’t need to be started to update, so w/ nodemon terminated, you should just be able to run ghost update and something should happen,


#5

I recorded a video so you can see, give it some time for youtube to render it

Or just how do you do it? I can use windows too


#6

You don’t need to run nodemon start to update ghost

After you run nodemon start, assume you can’t use that terminal window / tab anymore. You need to open a new terminal / tab to run commands.


#7

I did, and still doesn’t work, I’m pretty sure if I do it with npm it would work but nvm is not recognizing it, or something is happening… I’ll look around to see what’s wrong, thanks vika


#8

Oops, I missed that part :see_no_evil: It looks like your path may not be configured properly

nvm ghost update won’t work, since nvm is used to control what version of node you’re using, not to run a node command. Since you’re using nvm, make sure the node version is the same version you used to install Ghost, otherwise the ghost command won’t work


#9

that prob why, let me check :raised_hands:

Oh man… this is so tiresome… look at this:

and guess what… I obviously installed it with a root user… fff… no ending…

EDIT: It had nothing to do with installing it with root. I uninstall nvm and install npm with homebrew and homebrew didn’t have the supported version of node lol so I went back to nvm with the same process and it worked, something that was maybe cause this problem that was not a problem is that when I did ghost install local on a folder that had a space: ghost install, it said that the dir was not empty… maybe the version was not even the probl after all … :confused: well… if someone runs into this problem check all that lol


#10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.