Wordpress Plugin error 500


#1

Hi!

I’m trying to use the wordpress plugin, but it gives me error 500. I tried increasing php timeout to 3000 sec, but it doesn’t help (this fix is mentioned here)


#2

Is the wordpress install running locally aswell? I typically get error 500 when either 1. ports are not configured correctly or 2. permissions are not configured correctly.


#3

what do you mean locally? It’s on a VPS


#4

I mean I host my own servers. So I was asking if you were hosting your own server. Typically makes things easier to debug when you have root access. If its on a a VPS what OS, what VPS, what distro, what server are you using i.e. (apache or nginx) I need the details if I’m going to help you son.


#5

it’s ubuntu 16.04 with apache, hosting is flops.ru


#6

If you’re getting stuck on getting the information OUT of the VPS, as in the timeout increase is not helping it could mean a few things. If its a huge blog with lots of content the VPS instance is running out of /tmp or ram before it can clear the buffer and write the .json file. Try increasing the timeout to something like 3000 seconds. If that still doesn’t work then your going to have to use some mysql commands over SSH (if the WP isntall is using mySql) to write the database to a file and then SCP that to your computer. Then do a local mysql install, and a local wordpress install. Use the mysql command line again to import the database you downloaded via SCP to a local database with an identical name to the one used on the VPS server. Point local wordpress to local MySQL/DB. When it boots up you should see something identical to web based version. Create .json from that. No more silly virtual restrictions.


#7

thanks! I feared I’d have to do that.
I set timeout to 3000 sec exactly and it didn’t work. VPS stats show that only 65% of RAM is used, so that’s not the problem.


#8

The only other thing I can think of is the apache/php user doesn’t have write permissions to wherever the temporary .json file is being stored before being served to you. See if you can figure out how to change that directory to one that you know is writable. Do you have SSH access to vps? Type journalctl -fxe . If you have tmux I’d suggest doing tail -f on all the pertinent log files in /var/log/ like the php and apache logs. Then you’ll be able to see whats happening in real time at the system level, PHP level, and apache level all at the same time. You should be able to sort out whats broken pretty fucking quickly. What does it say?


#9

I ran it and it gives a bunch of text, mostly some error requiring ssh key


#10

You’re supposed to run that command BEFORE you export. It shows the system logfiles in real time as they’re being written to so you don’t have to call that command multiple times. It probably won’t show you much since VPS servers are very restrictive. What about the php & apache log files?


#11

opened apache logs, it says not enough memory! will try increasing it


#12

HAHAH told you mothafucka you’re welcome! :kissing_heart:


#13

json file downloaded, but it’s empty(


#14

Yes. That’s a good start. Set it to something like 1GB. I think a typical fresh php install will default to something like 128mb. Don’t forget to restart the server after changing the files so they take effect. :wink:


#15

I managed to solve the 500 problem (increased memory setting in php.ini to 1024MB), but now it gives me an empty json. increasing the memory to 16GB doesn’t help(


#16

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.