Admin API endpoint fails with ghost docker

I’m trying to integrate ghost with iA Writer. After getting an error in iA writer, I set up a request manually in Paw, verified it worked with a DigitalOcean ghost installation, and tried on my ghost docker instance.

The instance is running swimmingly, the only modification I made was to mount the content/data folder from my local machine. Everything seems to work, site loads, I can create, edit, delete, posts.

I set up an integration as per the docs but get an error

{"errors":[{"message":"Unknown Admin API Key","context":null,"type":"UnauthorizedError","details":null,"property":null,"help":null,"code":"UNKNOWN_ADMIN_API_KEY","id":"388c2080-a2b1-11ea-a66e-db9803cd6a2a"}]}

Looking at the source code, it appears this will return if it fails to retrieve an API key record for the passed in ID.

So I instead changed

models.ApiKey.findOne({id: apiKeyId}).then((apiKey) => {

to something like

models.ApiKey.collections().fetch().then(keys...

And verified it was returning all the keys as JSON.

It appears if you call .get on any one of those keys, you get an authorization failed error. And that’s where I’m not sure what to investigate.

Could someone point me in the right direction please?

Update: I forgot to mention I’m editing to source code directly to pipe this key.get authorization error just to be sure it’s coming directly from the source. I also 777d the content dir recursively just to diagnose.