Cannot install Ghost locally Ubuntu 18.04


#1

I’m unable to install Ghost locally. I’ve got the following error. Any help would be appreciated.

Terminal output
user@host:~/dev/ghost-dev$ ghost install local
:heavy_check_mark: Checking system Node.js version
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking for latest Ghost version
:heavy_check_mark: Setting up install directory
:heavy_check_mark: Downloading and installing Ghost v2.15.0
:heavy_check_mark: Finishing install process
:heavy_check_mark: Configuring Ghost
:heavy_check_mark: Setting up instance
:information_source: Ensuring user is not logged in as ghost user [skipped]
:information_source: Checking if logged in user is directory owner [skipped]
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Validating config
:heavy_check_mark: Checking memory availability
:heavy_multiplication_x: Starting Ghost
A GhostError occurred.

Message: Ghost process exited with code: null

Debug Information:
OS: Ubuntu, v18.04
Node Version: v10.15.1
Ghost-CLI Version: 1.9.9
Environment: development
Command: ‘ghost install local’

Additional log info available in: /home/user/.ghost/logs/ghost-cli-debug-2019-02-24T19_39_51_768Z.log

user@host:~/dev/ghost-dev$ cat /home/user/.ghost/logs/ghost-cli-debug-2019-02-24T19_39_51_768Z.log
Debug Information:
OS: Ubuntu, v18.04
Node Version: v10.15.1
Ghost-CLI Version: 1.9.9
Environment: development
Command: ‘ghost install local’
Message: Ghost process exited with code: null
Stack: Error: Ghost process exited with code: null
at ChildProcess.cp.on (/usr/local/lib/node_modules/ghost-cli/lib/utils/local-process.js:56:24)
at ChildProcess.emit (events.js:189:13)
at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)

user@host:~/dev/ghost-dev$ ghost doctor
Found a development config but not a production config, running in development mode instead
:heavy_check_mark: Checking system Node.js version
:information_source: Ensuring user is not logged in as ghost user [skipped]
:information_source: Checking if logged in user is directory owner [skipped]
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Validating config
:heavy_check_mark: Checking memory availability


#2

Update
I’ve reproduced the bug on a virtual machine created on another computer so it seems to be an issue with Linux Ubuntu 18.04 and not only with my computer.

Is anyone using it successfully on Ubuntu 18.04?


#3

Update
I’ve installed it with node 8 and it work.

Is there an open issue for this problem with Node 10.15.1 on Ubuntu?


#4

@dbouchard I’ve just tested this with a fresh Ubuntu 18.04 VM and I’ve been unable to reproduce.

> curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash
> sudo apt-get install -y nodejs
> node -v
v 10.15.2
> sudo npm -i ghost-cli
> mkdir dev-blog
> cd dev-blog
> ghost install local
✔ Checking system Node.js version
✔ Checking current folder permissions
✔ Checking memory availability
✔ Checking for latest Ghost version
✔ Setting up install directory
✔ Downloading and installing Ghost v2.16.2
✔ Finishing install process
✔ Configuring Ghost
✔ Setting up instance
ℹ Ensuring user is not logged in as ghost user [skipped]
ℹ Checking if logged in user is directory owner [skipped]
✔ Checking current folder permissions
✔ Validating config
✔ Checking memory availability
✔ Starting Ghost

Ghost uses direct mail by default. To set up an alternative email method read our docs at https://docs.ghost.org/concepts/config/#mail

------------------------------------------------------------------------------

Ghost was installed successfully! To complete setup of your publication, visit: 

    http://localhost:2368/ghost/

#5

Thank you for the follow up.

My workaround is to work with Node 8 for the moment (I can live with that for now). I will try again with the new Node version (10.15.2 instead of 10.15.1) and Ghost version (2.16.2 instead of 2.15.0) in a VM later to see if something change.


#6

I confirm that it work now, thank you!


closed #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.