Can't send transactional emails


I have tried every suggestion under the sun for the mail config part of “config.production.json” several mailguns and several gmails.

My ghost install works. I can browse the blog, just can’t do signups…
“Failed to send magic link email”

I allowed ports 465 and 587 in ufw. I even disabled ufw for testing purposes.

Here are my details:

Ghost-CLI version: 1.24.0
Ghost version: 5.33.0

:heavy_check_mark: Checking system Node.js version - found v16.19.0
:heavy_check_mark: Checking logged in user
:heavy_check_mark: Ensuring user is not logged in as ghost user
:heavy_check_mark: Checking if logged in user is directory owner
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking system compatibility
:heavy_check_mark: Checking for a MySQL installation
Instance is currently running
:information_source: Validating config [skipped]
:heavy_check_mark: Checking folder permissions
:heavy_check_mark: Checking file permissions
:heavy_check_mark: Checking content folder ownership
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking binary dependencies
:heavy_check_mark: Checking free space
:heavy_check_mark: Checking systemd unit file
:heavy_check_mark: Checking systemd node version - found v16.19.0

Distributor ID: Ubuntu
Description: Ubuntu 20.04.5 LTS
Release: 20.04
Codename: focal

here is the entire config:

“url”: “”,
“server”: {
“port”: 2368,
“host”: “”
“database”: {
“client”: “mysql”,
“connection”: {
“host”: “localhost”,
“user”: “ghostcms”,
“password”: “mypass”,
“database”: “myblog_prod”
“mail”: {
“transport”: “SMTP”,
“options”: {
“service”: “Google”,
“host”: “”,
“port”: 587,
“auth”: {
“user”: “”,
“pass”: “zygauffuaevnfrce”
“logging”: {
“transports”: [
“process”: “systemd”,
“paths”: {
“contentPath”: “/var/www/myblog/content”

Any ideas?

Thank you,

my VPS host has mail ports blocked…
i was going crazy.
do yourself a favor and check with your host first