Email Subscribe Transaction Email Isn't sending

Hey all!
I’m having a lot of trouble with getting email subscribe transaction emails to send when a visitor subscribes.

I’ve been crawling the ghost forums for about 4 hours and still can’t get this to work so any help would be greatly appreciated!!

URL - https://andydao.co/
Version of Ghost - 3.40
Browser - Chrome
Setup - Digital Ocean + Ghost + Mailgun for bulk and transactional emails

What I’ve done:

  1. I’ve configured my config.production.json log to match the attached image - followed this tutorial - How To Set Up Transactional Emails in Ghost

  2. Team member invites are successfully being sent via mailgun - this is showing up in the mailgun analytics and i’m receiving the emails

  3. Subscriber confirmation emails are not being sent at all

  4. I’ve updated the newsletter email and support email address to hey@andydao.co and all checks have passed on mailgun for emails to be sent via this domain.

If I can provide anything else do let me know!

  • "port": 465 should be "port": 587, 465 is no longer recommended
  • "secureConnection": true should be "secureConnection": false, this will use STARTTLS after connecting so the connection is still secure bit it means the initial connection doesn’t require matching protocols up-front
  • "service": "Mailgun" isn’t required because you’re setting the connection details manually but this shouldn’t stop anything from working
1 Like

Hey Kevin, thanks for getting back to me.

What was suggested above didn’t solve the problem though :frowning:

After tweaking things a bit with a fresh mind, turns out you have to allow free members to sign up in the members section for this to work.

Just in case anyone else bumps into the same problem, I just recently started getting ERR_SSL_WRONG_VERSION_NUMBER errors in Ghost log (Digital Ocean Ghost install droplet) and subscribing did not work anymore (I have members enabled).

Changing "secureConnection": false in config.production.json seem to fix the problem. Not sure why it worked before with the setting set as true though :slight_smile: