If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue
  • What version of Ghost are you using?
    ghost - 3.3
    ghost cli - 1.13.1
  • What configuration?
    ssl and acme issue
  • What browser?
  • What errors or information do you see in the console?
    The site can’t be reached.
  • What steps could someone else take to reproduce the issue you’re having?
    Had an issue with selective browser SSL issue.
    Checked available certificate and it was valid June 25.
    /etc/letsencrypt/ --home "/etc/letsencrypt" --list

Main_Domain KeyLength SAN_Domains Created Renew "" no Mon Mar 16 00:00:49 UTC 2020 Fri May 15 00:00:49 UTC 2020

Forced to issue a new certificate and reload Nginx.

/etc/letsencrypt/ --home "/etc/letsencrypt" --renew -d --force

Now I am getting an issue with all the browsers.

How do I troubleshoot this? I am running out of options. Is there any way to uninstall SSL alone and re-install it?

I have noticed SSL handshake error.

2020/03/28 04:45:06 [error] 2802#2802: *54 connect() failed (111: Connection refused) while connecting to upstream, client:, server:, request: "GET / HTTP/1.1", upstream: "".

My server block headers are default. Is there anything I have to do at the client-side?

One of my laptop is working. iPhone X safari and chrome are having this error.

Is this a non-issue at the setup?

Final Update

Turns out, my domain has expired by yesterday. Thanks to that ignorance, I have learned some new things today with SSL, Certbot, acme, and Ghost ssl setup.


Hey @Gj_Jo :wave:

It looks like the site is working now, did you get everything resolved?

Yes, I have identified the issue and fixed it.
Thanks for addressing my incident.

really appreciate it.