Fail WordPress Migration

Hello Everyone

I am having issue with the Wordpress Ghost Plugin ( Export to Ghost)
I am unable to download Ghost File and JSON File

I keep getting the following error “There has been a critical error on this website. Please check your site admin email inbox for instructions.”

Ghost Migrator 1.0.3 - Diagnostics

PHP version: 5.6.27.

PHP ZipArchive Installed: Yes

Memory Limit: 256M

Max Execution Time: 30


What should my next steps be?

Hi,

You might need to update your PHP version from 5.x.x to 7.x.x to make this work. Not sure if the plugin works with a PHP version that old.

FYI: before you change your PHP version, make sure to talk to your host before doing so since that can cause your site to crash depending on the code used in your theme, plugins and what not.

Make sure your WP version matches the plugin requirements. You can use wp_config.php to turn on debug mode to find out if the plugin is causing issues.

You can read about that here:

Next is making sure you have done the conversion part before doing the export.

Make sure your PHP is set to allow a file_size of minimum XX whereof XX matches the size of your entire post content. Start with 8mb and see where that takes you. Also, make sure that the time out is set to more than 30. You can ask your host for advice on this as well.

Please also make sure to read the official doc on this:

Hello Bear

I have update the php version and I am still getting the same error

Ghost Migrator 1.0.3 - Diagnostics

PHP version: 7.3.26.

PHP ZipArchive Installed: No

Memory Limit: 256M

Max Execution Time: 30


From the Debug Log

[11-May-2021 01:21:01 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:21:01 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:21:04 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 2097152 bytes) in /home/rrubhufpbq7j/public_html/wp-includes/functions.php on line 3955
[11-May-2021 01:21:11 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:21:11 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:21:13 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 4198400 bytes) in /home/rrubhufpbq7j/public_html/wp-includes/functions.php on line 3955
[11-May-2021 01:21:18 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:21:18 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:21:21 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 4198400 bytes) in /home/rrubhufpbq7j/public_html/wp-includes/functions.php on line 3955
[11-May-2021 01:37:44 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:37:44 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:37:47 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 2097152 bytes) in /home/rrubhufpbq7j/public_html/wp-includes/functions.php on line 3955
[11-May-2021 01:37:51 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:37:51 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[11-May-2021 01:37:54 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 4198400 bytes) in /home/rrubhufpbq7j/public_html/wp-includes/functions.php on line 3955

By the looks of it, the theme does something weird that causes memory exhaustion after the PHP upgrade. I would talk to the theme developer and to your host about that. You should be on PHP 7.4.x and not 7.3.x. Also, make sure you have enabled the zip PHP feature.

For the migration part and errors referring to that, I would ask one of the staff members (Kevin or Hannah perhaps) to have a look.

So I took your advice and Updated PHP and turn on PHP ZipArchive. I switch the theme on Wordpress to default 2021 theme.

I am still getting the same error

Ghost Migrator 1.0.3 - Diagnostics

PHP version: 7.4.14.

PHP ZipArchive Installed: Yes

Memory Limit: 256M

Max Execution Time: 30

[15-May-2021 01:30:43 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[15-May-2021 01:30:43 UTC] PHP Notice:  Trying to access array offset on value of type null in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[15-May-2021 01:30:43 UTC] PHP Notice:  Undefined index: description in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[15-May-2021 01:30:43 UTC] PHP Notice:  Trying to access array offset on value of type null in /home/rrubhufpbq7j/public_html/wp-content/plugins/ghost/class-ghost.php on line 413
[15-May-2021 01:30:46 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 1241088 bytes) in /home/rrubhufpbq7j/public_html/wp-includes/functions.php on line 3955

I have updated the upload size to 128MB and even the post max size to the same.
The execution time was already at 30 and I have increased it to 50.
Still getting the same error

I have disabled all plugins and i am running 5.7.2 Wordpress
I am getting error both on ghost file and json file
I have 1,509 Posts on Wordpress
I have already increasing the limits with to 128MB and even the post max size to the same. The execution time was already at 30 and I have increased it to 50.
This is the max allow by my hosting provider
I am getting the error on Export to JSON as well

What should I do next?