Ghost Blog goes into Bad Gateway, no idea why


#1

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? https://intheair.aersure.com
  • What version of Ghost are you using? 2.7.0 (recently updated)
  • What configuration? Installed on Digital Ocean
  • What browser? Chrome
  • What errors or information do you see in the console? No errors that I can see
  • What steps could someone else take to reproduce the issue you’re having? Visiting the site throws 502 Bad Gateway nginx/1.14.0 (Ubuntu).

I’m not sure what to do. It happened overnight, I tried restarting ghost itself multiple time, tried restarting the server, I ran Ghost Run and got this back:

The `ghost run` command is used by the configured Ghost process manager and for debugging. If you're not running this to debug something, you should run `ghost start` instead.
[2018-12-05 06:05:00] WARN Theme's file locales/en.json not found. 
[2018-12-05 06:05:01] INFO Ghost is running in production... 
[2018-12-05 06:05:01] INFO Your blog is now available on https://intheair.aersure.com/ 
[2018-12-05 06:05:01] INFO Ctrl+C to shut down 
[2018-12-05 06:05:01] INFO Ghost boot 5.147s

Not very tech inclined, but can follow step my step instructions. Any ideas how to go about fixing this?


#2

Visiting https://intheair.aersure.com/ loads fine for me :smiley: Did you get it fixed? If so, please add a response/solution so you can help others having the same problem!


#3

Right! Sorry I was a little busy yesterday, didn’t get a chance to update!

I fixed it by accident.

When I first installed Ghost, it said that port 2368 is used and so I changed it to port 2369. What happened was, overnight my Digital Ocean server decided 2369 is going to be used by itself for whatever reason.

Switching port back to 2368 in config.production.json fixed the issue for me.