Ghost-cli bug or something else?

OS: FreeBSD 13

Current version: 5.66.1
Latest version: 5.68.0

You are running an outdated version of Ghost-CLI.
It is recommended that you upgrade before continuing.
Run npm install -g ghost-cli@latest to upgrade.

:heavy_check_mark: Checking system Node.js version - found v18.18.0
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking free space
:heavy_check_mark: Checking for available migrations
:heavy_check_mark: Checking for latest Ghost version

# npm install -g ghost-cli@latest
changed 597 packages in 1m

$ ghost update

☲ Inspecting operating system/usr/local/lib/node_modules/ghost-cli/node_modules/systeminformation/lib/osinfo.js:275
          const logofile = util.getLogoFile(distro);
TypeError: util.getLogoFile is not a function
    at /usr/local/lib/node_modules/ghost-cli/node_modules/systeminformation/lib/osinfo.js:275:33
    at ChildProcess.exithandler (node:child_process:414:7)
    at ChildProcess.emit (node:events:517:28)
    at maybeClose (node:internal/child_process:1098:16)
    at Socket.<anonymous> (node:internal/child_process:450:11)
    at Socket.emit (node:events:517:28)
    at Pipe.<anonymous> (node:net:350:12)

Node.js v18.18.0

ghost-cli version 1.24.2 works perfectly, after upgrading to whatever the lastest version is, I cannot start ghost, cannot update ghost, nothing works including ghost buster, ghost doctor, …

Reverting back to ghost-cli v1.24 allows me to at least run ghost, but wouldn’t want to be stuck here. Could use some insight and help.

PS: running npm@10.2.0
PPS: updated to node v18 as per your recommendation and ghost will not update unless the cli is updated which in turn won’t update unless node is updated (if at this point I remember correctly)

There’s a pull request to fix this in the Ghost-CLI already. Once that’s merged and released it will resolve the issue:

1 Like

Is Ghost working for you on FreeBSD otherwise?

I used to run a web hosting business on FreeBSD and it was rock-solid stable for me.

1 Like

Oh, AWESOME, thank you so much for that note!
Wouldn’t even know how to look for this anomaly [by name] and whether it’s being worked on otherwise.

Forgive my ignorance, how do I check when this fix has been merged and released? I can usually find what I need on git but I don’t do development so not familiar with those functions.

I self-host a Production version on FreeBSD 13 and it’s been running solidly. Then again it’s running as a hobby. It does require some reading and hacking (problem-solving) from time to time, but it works very well.

  • For example I had to do some digging to get my mail provider to work since Ghost prefers railgun or whatever it’s called
  • Got an error this morning about Ghost not being able to connect to mysql; come to find out, the new code (v5.66.1) prefers IPv6 when interpreting localhost, so updated my.cnf.

One thing that I do find goofey is that node (javascript?) is so slow.
If I run php-cli versus ghost-cli, php feedback is practically immediate, so is the bash shell. Then again my interaction with node is minimal hence don’t care too much.

Thanks again for writing … you saved some hair today! :joy:

1 Like