Ghost-CLI failing on: Checking folder permissions

ghost-cli

#1

I posted a bug report, but it got closed. Nonetheless it has detailed information on my issue so I’ll link it anyways: Ghost-CLI failing on: Checking folder permissions.

After restarting the installation from scratch a couple of times I found that it successfully goes through the entire installation. At the end, when it asks if I want to start ghost, I select yes. Then when it tried to start ghost it fails. If I try ghost run it works just fine and I can view the blog in my browser.

To clarify I did run the line of code it told me too and followed the instructions. I retried the installation about a dozen times by now in case I did mess up a step…

Any ideas?


#2

So I discovered the issue arose from special permission modes: setuid, setgid, and sticky bit. I removed them using sudo chmod 000775 on the relevant folders. I set these permission modes on my var/www folder for another reason and creating a new folder in this directory seemed to carry these settings over to the new folder. Maybe the check can consider these and propose a command to fix this so future users do not get stuck like I did? Anyways hope this helps anyone else with the same issue as me!


#3

This was actually discussed (if memory serves me this was in slack) and we decided against it because it adds a lot of development overhead (the check becomes exponentially more complicated) and the benefit is relatively minimal

That being said, there is a warning in the docs outlining the CLI’s lack of support for directory flags.


#4

Ah okay thanks. It might help to move that warning to the ghost output or at least put it in the installation or troubleshooting sections too… despite reading almost all of the cli docs, I did not ever think to check the bottommost link. Although I think the most obvious solution would be to have the output recommend running: sudo chmod g-s /var/www/ghost/* -R if sudo find /var/www/ghost/* -type d -exec chmod 775 {} \; does not fix the problem.


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.