Ghost install not working on Raspberry Pi; error at 3/5 downloading Yarn

The specific error I’m getting is
error An unexpected error occurred: “ ESOCKETTIMEDOUT”.

I ran ghost install --verbose in /var/www/ghost after giving the pi account permissions on the folder.

Ghost version: 3.30.0
NPM version: 6.14.8
Node version: 10.21.8

I’ve tried wiping the ghost directory a couple times and re-running the installer, but it takes a long time to do and every time Yarn whines about a timeout error

I ran Ghost Buster to clear the Yarn cache.

I also tried installing yarn with apt-get and then running “yarn install --network-timeout 1000000”, which got me “yarn: error: no such option: --network-timeout”

Is there a way to install yarn and increase the timeout manually, or just stick the file on there (I can defiinitely download it on my chromebook on the same network) and continue the installation, or maybe somehow manually install ghost?

I’ll try and help. What model Raspberry Pi are you using? Also, what OS? 32 or 64 bit OS?

Thanks! It’s a Pi Zero W, running Raspbian version 10 (buster) 32-bit.

Sure, no problem! Have you tried installing the latest version of yarn like this?

cd /var/www/ghost
curl -sS | sudo apt-key add -
echo "deb stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt-get update
sudo apt-get install yarn
yarn config set network-timeout 180000

Give that a shot and then you should be able to complete the ghost install.