Ghost Installtion on Windows server with IIS IISNode

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue tempurl
  • What version of Ghost are you using? 5.65.0
  • What configuration? IISNode
  • What browser? Chrome
  • What errors or information do you see in the console?

TypeError: Cannot read properties of undefined (reading ‘connection’)
at Object.sanitizeDatabaseProperties (h:\root\home\irrefutablegames-003\www\ChrisStone\current\core\shared\config\utils.js:65:25)
at Object.loadNconf (h:\root\home\irrefutablegames-003\www\ChrisStone\current\core\shared\config\loader.js:53:16)
at Object. (h:\root\home\irrefutablegames-003\www\ChrisStone\current\core\shared\config\index.js:3:25)
at Module._compile (node:internal/modules/cjs/loader:1159:14)
at Module._extensions…js (node:internal/modules/cjs/loader:1213:10)
at Module.load (node:internal/modules/cjs/loader:1037:32)
at Module._load (node:internal/modules/cjs/loader:878:12)
at Module.require (node:internal/modules/cjs/loader:1061:19)
at require (node:internal/modules/cjs/helpers:103:18)
at bootGhost (h:\root\home\irrefutablegames-003\www\ChrisStone\current\core\boot.js:454:18)

  • What steps could someone else take to reproduce the issue you’re having? download ghost, locally via npm install upload via filezilla - change a couple files not sure if all to use PORT instead of env.

willing to try all fixes thank you!

TypeError: Cannot read properties of undefined (reading ‘connection’)
at Object.sanitizeDatabaseProperties (h:\root\home\irrefutablegames-003\www\ChrisStone\current\core\shared\config\utils.js:65:25)

It’s saying your database connection isn’t working. Do you have a MySQL server running? Can you connnect to it manually? are the connection details in config.production.json.

Since Windows Server is not supported, I don’t feel optimistic about your chances of getting this working even if you get the DB connection working.

When I created it locally I saw the database works, If anyone can get it to work it would be( with your guys help of course)

I have access to both mssql and mysql, but I thought it was running with sqlite3

As for the config

“url”: “”,
“server”: {
“port”: 2368,
“host”: “”
“database”: {
“client”: “sqlite3”,
“connection”: {
“filename”: “current/content/data/ghost-dev.db”
“mail”: {
“transport”: “Direct”
“logging”: {
“transports”: [
“process”: “local”,
“paths”: {
“contentPath”: “content”

You said this is a “server”, not a desktop, so I assume you are running in production mode with MySQL. You should check that your database settings in config.production.json are correct and that you connect to MySQL on your CLI with those settings.

1 Like

Ahh I’m running in development mode, something I researched said since it’s iisNode it would be better to run it with local configs and just push that to the server.

sorry for the confusion I can try this way though above is my config.development.json though

Ok. I’m not sure it’s not connecting then.

I guess , I will try production and go from there