Ghost not starting ( Freezes in Starting Ghost )

Hello,

Recently i updated Ghost CLI, Node Version
When i am trying to start or restart ghost its not working…
Here following the information

mydemo@server91:~/public_html/etube$ ghost start

  • sudo systemctl is-active ghost_etube-demo
  • sudo systemctl reset-failed ghost_etube-demo
    :heavy_check_mark: Ensuring user is not logged in as ghost user
    :heavy_check_mark: Checking if logged in user is directory owner
    :heavy_check_mark: Checking current folder permissions
  • sudo systemctl is-active ghost_etube-demo
    :heavy_check_mark: Validating config
    :heavy_check_mark: Checking folder permissions
    :heavy_check_mark: Checking file permissions
    :heavy_check_mark: Checking content folder ownership
    :heavy_check_mark: Checking memory availability
  • sudo systemctl start ghost_etube-demo
    ☴ Starting Ghost

My ghost and Ghost-CLI version :
Ghost-CLI version: 1.11.0
Ghost version: 2.23.3

Node : v10.13.0
Nodejs : v6.17.1

Please help me to fix that.

Nodejs 6 is deprecated. You should use node 10.

Yes… it was nodejs issue

1 Like

In my case i ran: ghost update --force

I have a similar issue at the moment and will happily start a new thread if deemed warranted.

I’ve just upgraded to node v10.16.0 after seeing @pascalandy note that version 6, which I was running, was deprecated (thanks for that pointer).

My blog was running fine until I ran ghost update to upgrade my blog to 2.25.0 (previous version was either 23 or 24, apologies, I didn’t note which). Initially the upgrade complained about the npm version but that’s sorted now.

The Ghost service isn’t running following the upgrade. Indeed, issuing ghost start says:

+ sudo systemctl start ghost_localhost
  Starting Ghost

and then just hangs.

Running ghost run allows the blog to start correctly.

System is is Debian 9.9 with Nginx serving Ghost. I note the Ghost server isn’t running hence bad gateway messages.

I’ve tried ghost update --force which completed successfully but didn’t resolve the issue.

Incidentally, if I execute ghost run the blog starts correctly.

Any advice please?