Ghost v1.25.8 is not compatible with the current Node version 10.15.1?

Hi,
I tried to upgrade Ghost from v1.0 to v2.0 and got this error.

Ghost v1.25.8 is not compatible with the current Node version.

My environment is:

OS: Ubuntu, v16.04
Node Version: v10.15.1
Ghost-CLI Version: 1.11.0

and Ghost version is:

ghost version
Ghost-CLI version: 1.11.0
Ghost version: 1.22.2 (at /var/www/ghost)

The error occurred when I tried to update Ghost to latest V1.0 before V2.0 as per the instruction:

ghost update --v1

  • sudo systemctl is-active ghost_blackshadowgame-com
    :heavy_check_mark: Checking system Node.js version
    :heavy_check_mark: Ensuring user is not logged in as ghost user
    :heavy_check_mark: Checking if logged in user is directory owner
    :heavy_check_mark: Checking current folder permissions
    :heavy_check_mark: Checking folder permissions
    :heavy_check_mark: Checking file permissions
    :heavy_check_mark: Checking content folder ownership
    :heavy_check_mark: Checking memory availability
    :heavy_check_mark: Checking for available migrations
    :heavy_check_mark: Checking for latest Ghost version
    :heavy_multiplication_x: Downloading and updating Ghost to v1.25.8
    A SystemError occurred.

Message: Ghost v1.25.8 is not compatible with the current Node version.

Debug Information:
OS: Ubuntu, v16.04
Node Version: v10.15.1
Ghost-CLI Version: 1.11.0
Environment: production
Command: ‘ghost update --v1’

And everything was fine when running ghost doctor

ghost doctor
:heavy_check_mark: Checking system Node.js version
:heavy_check_mark: Checking logged in user
:heavy_check_mark: Ensuring user is not logged in as ghost user
:heavy_check_mark: Checking if logged in user is directory owner
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking operating system compatibility
:heavy_check_mark: Checking for a MySQL installation

  • sudo systemctl is-active ghost_blackshadowgame-com
    :heavy_check_mark: Validating config
    :heavy_check_mark: Checking folder permissions
    :heavy_check_mark: Checking file permissions
    :heavy_check_mark: Checking content folder ownership
    :heavy_check_mark: Checking memory availability

whereis node
node:
/usr/local/bin/node.bk (<=== v10.16.0)
/home/zhangzhibin/.nvm/versions/node/v10.15.1/bin/node (<=== v10.15.1)

Any suggestion?

Thanks,
Devon

Hey @zhangzhibin :wave: The Ghost v1.x version was never upgraded to support Node v10, but should have been. We plan to release a patch next Tuesday for this.

In a meanwhile think the best way around this situation is temporarily upgrading using Node v8 and then bumping Node version to v10 once the upgrade is done.

1 Like

Thanks!
I installed Node v8 and it works now.