Ghost v4.9.4 is not compatible with the current Node version

Hi, Im trying to install locally on a mac, getting this error, even though Ghost 4 should support node 14 as far as I can tell? (Would perhaps be more helpful if Ghost gave you some clue as to what node version it expects in this case?)

Debug Information:
OS: macOS, v11.4
Node Version: v14.16.0
Ghost-CLI Version: 1.17.3
Environment: development
Command: ‘ghost install local’

Hi @tompi :wave: due to nodejs security updates, the minimum node version is v14.16.1, while you’re on v14.16.0

Use engines.node in Ghost/package.json at main · TryGhost/Ghost · GitHub

Thank you, installed 14.17 and everything went ok.

1 Like

This is a good point! We’ve updated the help text to include the required semver ranges in the error message. This will be included in the next release of the CLI