Ghost was able to start, but errored during boot with: Knex: run

I’ve been trying to install Ghost on my shared server using cpanel terminal but it’s giving me the following error,
I don’t know understand what I’m doing wrong and I’ve already reinstalled it more than 5 times but I’m facing the same error always,
from my research, I think it has something to do with the GCC compiler and Ghost-CLI is not able to connect to it so help me out.

:heavy_check_mark: Checking system Node.js version - found v14.18.3
:information_source: Ensuring user is not logged in as ghost user [skipped]
:information_source: Checking if logged in user is directory owner [skipped]
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Validating config
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking binary dependencies
:heavy_multiplication_x: Starting Ghost: ghost-local
A GhostError occurred.

Message: Ghost was able to start, but errored during boot with: Knex: run
$ npm install sqlite3 --save
/lib64/libstdc++.so.6: version `CXXABI_1.3.8’ not found (required by /home/maaenter/thedistractedmonkey/versions/4.47.2/node_modules/sqlite3/lib/binding/napi-v6-linux-glibc-x64/node_sqlite3.node)

Debug Information:
OS: unknown, vunknown
Node Version: v14.18.3
Ghost Version: 4.47.2
Ghost-CLI Version: 1.19.3
Environment: development
Command: ‘ghost start’

Additional log info available in: /home/maaenter/.ghost/logs/ghost-cli-debug-2022-05-15T12_49_15_909Z.log

Try running ghost doctor to check your system for known issues.

You can always refer to Ghost-CLI - A fully loaded tool for installation and configuration for troubleshooting.

I was successfully able to install Ghost 4.3.3 but for some reason whenever I try to install the latest version or update it to the latest version it gives me the same error I’ve shown above.