Ghost won't start after (kinda failed) Update

  • What’s your URL? This is the easiest way for others to debug your issue
    Ghost URL is
  • What version of Ghost are you using?
    :/var/www/ghost$ ghost version
    Ghost-CLI version: 1.11.0
    Ghost version: 2.25.7 (at /var/www/ghost)
  • What configuration?
    Standard Install with no modifications
  • What browser?
  • What errors or information do you see in the console?
    + sudo node current/index.js
        throw err;

    Error: Cannot find module 'ghost-ignition'
        at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
        at Function.Module._load (internal/modules/cjs/loader.js:562:25)
        at Module.require (internal/modules/cjs/loader.js:690:17)
        at require (internal/modules/cjs/helpers.js:25:18)
        at Object.<anonymous> (/var/www/ghost/versions/2.25.7/index.js:5:13)
        at Module._compile (internal/modules/cjs/loader.js:776:30)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:787:10)
        at Module.load (internal/modules/cjs/loader.js:653:32)
        at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
        at Function.Module._load (internal/modules/cjs/loader.js:585:3)
  • What steps could someone else take to reproduce the issue you’re having?

*Additional context: I’ve been on a long vacation and ghost wasn’t updated in last two months. It was working fine before update but I like to keep software up to date so I performed update anyway. Here, my laptop lost it’s juice and decided to die. As I got it back alive, Ghost (which is hosted in vultr cloud) was 502

I tried ghost update and it went smooth except that it got stuck at restarting ghost and went nowhere. I’ve since tried to start it by ghost start but that also goes nowhere. So I performed a ghost run and got the above error in ssh console.

I see it complaining about ghost-ignition I have zero idea what that it or how to fix this situation.

any help will be highly appreciated :slight_smile:

1 Like

Did you perchance update node at some point?

I recommend trying ghost update --force to rerun the upgrade.


I doubt that since node isn’t updated with the regular apt-get upgrade routine afaik.

I’m giving this a try, will report back in a moment.

Thanks @Hannah, That fixed it. Thank you for saving my day (night) :slight_smile: