Ghost won't start after upgrading to MySQL 8

Running on Linux Mint 19.3 Cinnamon, Ubuntu Bionic
OS: LinuxMint, v19.3
Node Version: v14.17.0
Ghost Version: 4.36.2
Ghost-CLI Version: 1.18.1

Upgraded today to MYSQL8 from v5.7

Upgraded Ghost, wouldn’t start as gets stuck on the following error which I cannot clear:

Message: Ghost was able to start, but errored during boot with: alter table posts_products add constraint posts_products_post_id_foreign foreign key (post_id) references posts (id) on delete CASCADE - UNKNOWN_CODE_PLEASE_REPORT: Referencing column ‘post_id’ and referenced column ‘id’ in foreign key constraint ‘posts_products_post_id_foreign’ are incompatible.
Help: Error occurred while executing the following migration: 2022-01-20-05-55-add-post-products-table.js

I’ve seen suggestions for altering the DEFAULT CHARACTER SET and COLLATE but still have same error.

Any ideas?

Just found this bug, linked to Migration failed in latest version · Issue #288 · docker-library/ghost · GitHub. However, I am not using Docker but a standalone installation.

This solution worked for me: Migration failed in latest version · Issue #288 · docker-library/ghost · GitHub