I cannot access my site with "www" URL


#1

I can connect to my site as nerfia.com.
but I can not connect to my site as www.nerfia.com.

www.nerfia.com” can access my site. but go to nerfia.com URLs. how can I do that?


#2

Ghost itself can only ever have one domain pointed at it. This is intentional for SEO purposes, however you can always redirect extra domains to your Ghost install using nginx.

Check out : https://docs.ghost.org/api/ghost-cli/knowledgebase/#ssl-for-additional-domains

If you need more help here is step-by-step solution: https://www.digitalocean.com/community/questions/how-to-set-www-subdomain-for-one-click-ghost-with-ssl?answer=45728


#3

should I use this URL directory if this layout is really advantageous?
If the layout of the nerfia.com url is really good in the SEO system, I’d love to use it that way.


#4

You don’t need to go through all this process if you don’t want additional SSL, just make sure that you point your “www” CNAME to your non-www domain.

This is an example of DNS settings for digitalocean.com

±------------±------------------------±------------------------------------------+
| Type------| Hostname----------| Value -----------------------------------|
±------------±------------------------±------------------------------------------+
| CNAME | www.domain.com–| is an alias of domain.com---------|
| A----------| domain.com---------| directs to YOUR-SERVER-IP—|
| NS------- | domain.com-------- | directs to ns1.your-hosting.com |
| NS--------| domain.com-------- | directs to ns2.your-hosting.com |
| NS--------| domain.com---------| directs to ns3.your-hosting.com |
±-----------±-------------------------±-------------------------------------------+

(Note to myself: Forum System does not support ASCII tables)


#5

I just tried this (I needed to do it too, so I’m glad for this thread)… I’m on Digital Ocean. Entered CNAME fields exactly as instructed and trying to navigate to www results in security warnings and error. Does anything else need done? Or does it take awhile to settle in?


#6

It takes up to 24 hours for DNS cache to refresh (usually much less) , but you can use free proxy to avoid manually flushing it.


#7

Awesome, thanks. I can wait, still building the site.


#8

It’s highly recommended to always setup SSL for all URLs used to access Ghost. Even redirects.


#9

I just use nerfia.com URL without redirection. is there a disadvantage?


#10

As already explained, Ghost only allows 1 URL. Which you have setup as nerfia.com. If you’re setting up a second URL of www.nerfia.com, it should have SSL and it should be redirected.

These are the steps for how: https://docs.ghost.org/api/ghost-cli/knowledgebase/#ssl-for-additional-domains


closed #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.