Importing Content into Ghost - Error

When trying to import content we keep getting this error:
Failed to load resource: ghost/api/v3/admin/db/:1

Any ideas how to fix this?

Apparently, the admin api is not installed on a plain installation of Ghost (latest version)? This is strange. We went into the package.json and there is no @tryghost/admin-api. How do we get this installed? We tried installing it via NPM but got tons of errors.

Are you saying you tried importing via the Admin client and got the error? The Admin client doesn’t use the Ghost SDK as it directly makes API calls

Just saw your post on this thread:

A 504 error suggests that your proxy in front of Ghost (e.g. nginx) cancelled the request because it took too long. This is normal for larger imports since there’s more data to process.

Take a look at this post for Nginx configuration:

Are you saying you tried importing via the Admin client and got the error? The Admin client doesn’t use the Ghost SDK as it directly makes API calls

Yes. We are importing via the Admin and got that error in console. Actually, the admin just says the import failed and check the console for error. We then checked the console and it gave us that error. BTW, we are just importing 5 posts as a test, so it can’t possibly be some timeout error.

What errors do you get from the ghost instance?

ghost log -e

there is nothing in the log errors in the instance via the CLI. Attached is the log from the browser and console.error-console

apparently, the import functionality does rely on the api/v3/admin, but it’s not installed on the plain instance. If they explain how to install this, then I would imagine import would work.

Below is another error shown on the console:


running the import when reviewing network requests firefox console, clearly shows the api/v3/admin is requested on the import in the admin, and it throws a 504, because this endpoint doesn’t exist.

If you’re having issues importing to your production instance, I suggest installing locally to try to limit external issues. The HTT2_PROTOCOL_ERROR suggests there’s something wrong with your non-ghost config

ha, yes. Everything always works locally. :grinning:

The problem is getting stuff to work on a production server. We followed the directions exactly (Digital Ocean 1-click install - and everything else works). There is something wrong with the installation, that’s for sure. I see we are not the only ones experiencing the same issue ( see here: Import failed - I cannot import a migration archive, it fails!)
Unfortunately, updating the nginx config file doesn’t work as suggested there. Apparently, the import feature doesn’t work on production server based on the Digital Ocean install. What the problem is, I haven’t a clue.

I was hoping this would work, as I wanted to move from Wordpress. Hard to believe it’s so difficult. Spent a day on this, can’t get it work. Can’t imagine we will manually redo 4,000 posts in ghost. They got to figure out a better way to move from Wordpress to Ghost. The current process simply doesn’t work.