Impossible to Restart Ghost


I’m having an issue starting Ghost on Digital Ocean.

  • What’s your URL? This is the easiest way for others to help you is the URL where ghost will be setup

  • What version of Ghost are you using? If it’s not the latest, please update Ghost first before opening your topic

  • How was Ghost installed and configured? DigitalOcean Droplet

  • What Node version, database, OS & browser are you using? Node v16.15.1, OS: Ubuntu, v20.04.4 LTS, Ghost CLI 1.21.0.

  • What errors or information do you see in the console?

ghost start

Love open source? We’re hiring Node.js Engineers to work on Ghost full-time.

+ sudo systemctl is-active ghost_147-182-239-227
✔ Checking system Node.js version - found v16.15.1
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
+ sudo systemctl is-active ghost_147-182-239-227
✔ Validating config
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
✔ Checking binary dependencies
✔ Checking systemd unit file
✔ Checking systemd node version - found v16.15.1
✖ Starting Ghost: 147-182-239-227
A SystemError occurred.

**Message: Systemd process manager has not been set up or is corrupted.**
Help: Run ghost setup linux-user systemd and try again.
  • What steps could someone else take to reproduce the issue you’re having?
    ghost restart

After updating ghost, I’m trying to restart it, but it doesn’t work.

When I run the recommended ghost setup linux-user system the test gets skipped:
:information_source: Setting up Systemd [skipped]

I appreciate your help. Ghost is a running thing, so re-installing it and going from scratch isn’t a preferred option.

check the service file

from the above it looks like it is:
sudo vim /usr/lib/systemd/system/ghost_147-182-239-227.service

It could be owend by the wrong user. It should be root and not ubuntu

the path to ghost could have changed

which ghost


mine changed … i think … because i used sudo when upgrading or maybe something else.

it sounds to me something wrong with service file.


Thank you for your answer.

Which ghost returns /usr/bin/ghost.

I’m running commands with the ghost-mgr profile.

With that,
Also: -rw-r–r-- 1 root root 298 Jun 28 09:48 ghost_147-182-239-227.service

I had the path wrong above.

ll /usr/lib/systemd/system/ghost_*

I checked file ownership on mine, it’s ubuntu not root, but yea I know for sure it shouldn’t be the ghost* user that the CLI wants to setup.

Check the filepath to node in the *.service file matches what is returned by the which ghost command.