MacOS Install and node version


#1

Trying to install on my Mac, running node 9.2.0. And here comes the error.
The version of node.js you are using is not supported. - only up to 8.9.0"!!!_

The Ghost Doctor don’T work because I tryed a blank “development” system to set up, and that’s why the doctor don’t match.

I won’t likely downgrade node.js. Is there any other advice how to handle this? Or should I just wait until this problem is solved. I would realy desperate in trying the new version 2.0 - multi language is for me the function is was waiting for.

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue
  • What version of Ghost are you using?
  • What configuration?
  • What browser?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

#2

Hey, so, typically Ghost only officially supports the LTS versions of node, which I believe right now is v8 with v10 coming later. Once v10 is supported, then your v9 might work, but to install right now, you would prob have to downgrade, or wait.


#3

@GerhardMes if you absolutely have to, you can run GHOST_NODE_VERSION_CHECK=false ghost install local and it will override that check, however support is not guaranteed at all for any issues you may or may not run into running with node 9.


#4

How about installing with docker?


#5

Thanks for the advice. But unfortunately it didn’t worked out. But Thanks for your support.


#6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.