Mail setup problem signup/login

Dear Support-Community,

I am right now building my own Ghost blog based on the DigitalOcean Ghost-1-Click installation:

Ghost version: 3.13.4

I used Mailgun for the setup within Ghost and in the confi.production.json

When I try to signup here I get: “When Please enter a valid email address!”.

When I try to send a new email for a post this works perfectly fine.

Is there anything I missed?

Thank you and warm regards

try to check log from command ghost log in your droplets, because this response code 500 : internal server error

Not sure what your config is like, but this is mine (taken out auth details).

"mail": {
  "transport": "SMTP",
  "options": {
    "service": "Mailgun",
    "host": "",
    "port": 465,
    "secureConnection": true,
    "auth": {
      "user": "",
      "pass": "password"

Update the host, user and pass with your details. If you’re using an EU instance, then the host can stay, otherwise, change it as needed.

1 Like

Perfect, thanks a lot MichaelBrooks, the host was the issue even though I use the EU host :slight_smile:

It works now fine, thanks a lot :slight_smile:
Warm regards

There is only one issue I have now again :frowning:

Even though I have:
“mail”: {
“from”: “‘”,

It show me strange from addres and strange email symbols. Do you know where I can change this?! :slight_smile: