Mailgun SMTP error

I have correctly added the mailgun settings to the file. It gives this error when sending an invitation:

Error sending email! Error sending email: Failed to send email. Reason: 140360242898816:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332: . Please check your email settings and resend the invitation. 
1 Like

I got the exact same issue. Any updates?

So I’ve been trying to add a user now for a while and am always met with some new error. I am able to send email newsletters via Mailgun, so I know that’s configured right, but I still can’t seem to add contributors.

My URL is https://thefrightqueen.com. I’m running Ghost 4.5.0 and CLI 1.17.1 on Ubuntu 20.04 (DigitalOcean droplet). I’m using Nginx 1.18.0, MySQL 8.0.23 (fully installed), and Node.js 14.16.1. I’m on a Mac (11.2.3) using Chrome.

As it said in the docs, I edited my config.production.json file to include the following:

 "mail": {
"transport": "SMTP",
"options": {
  "service": "Mailgun",
  "host": "smtp.mailgun.org",
  "port": 587,
  "secureConnection": true,
  "auth": {
    "user": "postmaster@DOMAIN.com",
    "pass": "PASSWORD"
  }
}
  },

When I try to add a new contributor, I get the following:

“Error sending email! Error sending email: Failed to send email. Reason: 104542049400704"error"1408F10B:SSL routine:ssl3_get_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c332:. Please check your email settings and resend the invitation.”

Any help would be much appreciated. Thanks!

2 Likes

Please try changing to "secureConnection": false,

More details in this topic

2 Likes

Wow that worked for me! Thanks so much. It was driving me crazy.